Sales are not showing on the sales board
Incident Report for Avisi B.V.
Postmortem

Yesterday, on the 21st of May, we released a new version of Atlas CRM for Cloud. We released two improvements to Atlas CRM:
1. Performance and stability enhancements to the create issue screen in Atlas CRM
2. Improved user privacy by retrieving Atlassian user data through Atlassian's API instead of saving and fetching this data from our own database

This release resulted in sales in Atlas CRM to become inaccessible. This was caused by a bug in the code which tried to fetch assignees through Atlassian’s API.

We are sorry for the inconvenience this has caused and we are committed to finding and resolving these kinds of issues sooner. We will improve our workflow in the following two areas:
1. Our QA Workflow will be improved in order to find these bugs before they hit production.
2. We will monitor our logs better after a release in order to fix bugs ASAP which have slipped passed our QA team.

Posted May 22, 2019 - 15:15 CEST

Resolved
The issue has been resolved.
Posted May 22, 2019 - 15:08 CEST
Monitoring
The roll-out of the fix is complete. We are monitoring our logs for possible other related errors.
Posted May 22, 2019 - 10:02 CEST
Update
A fix is currently being deployed to our servers. Sales should be back on the board shortly.
Posted May 22, 2019 - 09:44 CEST
Update
Current estimation is that we will roll a fix within an hour.
Posted May 22, 2019 - 09:10 CEST
Update
We are continuing to work on a fix for this issue.
Posted May 22, 2019 - 09:09 CEST
Identified
We have found the issue and working on a fix. As soon as we have an estimation on when a fix will be applied, we will update you here.
Posted May 22, 2019 - 09:04 CEST
Update
We are continuing to investigate this issue.
Posted May 22, 2019 - 08:51 CEST
Investigating
We are investigating reports that sales are not showing on the sales board.
Posted May 22, 2019 - 08:50 CEST